OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: nsgmls not seeing dtd with emacs-21.2.-33 and psgml-1.2.3-7


I used to have psgml working with docbook xml on my windows box, but I
am now trying to get it going on Linux (RH 9) and am having a bear of a
time with it.

I have my SGML_CATALOG_FILES variable pointing to my catalog file, and
have managed to get emacs itself to see the dtd (it parses the dtd and
the tag-insert  functionality works as it should). 

However, nsgmls does not seem to see the catalog file, or something. The
catalog file declares the dtd in this way:

PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"    

Even though docbookx.dtd is in the same directory as the catalog, I
tried hard coding the path just to see what would happen. As you'll see
below, it didn't help. And I _do_ have OVERRIDE YES specified.

In the file I'm testing with, I have tried several versions of the
DOCTYPE declaration. If I do the following

       <!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"

nsgmls cannot find the dtd and so I get the following series of errors:

nsgmls:test.xml:4:75:E: cannot find "docbookx.dtd"; tried
"docbookx.dtd", "/usr/share/sgml/docbookx.dtd"
nsgmls:test.xml:4:75:E: DTD did not contain element declaration for
document type name
nsgmls:test.xml:8:5:E: element "BOOK" undefined
nsgmls:test.xml:9:10:E: element "TITLE" undefined
nsgmls:test.xml:9:37:E: general entity "org_client" not defined and no
default entity
nsgmls:test.xml:10:11:E: element "BOOKINFO" undefined
nsgmls:test.xml:11:12:E: element "AUTHOR" undefined
nsgmls:test.xml:12:11:E: element "FIRSTNAME" undefined
. . . 

If I do this:

       <!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"

I am giving nsgmls the entire path (which I should not have to do) and
so it seems to find the dtd, but then gives me this:

nsgmls -wxml -s  test.xml
nsgmls:/home/mrphil/data/DTDs/docbook/docbookx.dtd:74:15:W: named
character reference
nsgmls:/home/mrphil/data/DTDs/docbook/docbookx.dtd:74:17:E: "X20AC" is
not a function name
nsgmls:/home/mrphil/data/DTDs/docbook/ent/iso-amsa.ent:8:17:W: named
character reference
nsgmls:/home/mrphil/data/DTDs/docbook/ent/iso-amsa.ent:8:19:E: "X21B6"
is not a function name
. . . 

Any help would be appreciated.



[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]