OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Xalan, document(), and chunker.output.intent [WAS: base.dir param...]

Um, I won't claim to be an expert in various engines, but Xalan DOES 
support the document() function, or at least *a* document function. 
I've used it myself in previous scripts for years (the ones I'm 
replacing with the "standard" XSL package).  Are we talking about the 
same function?

As for Saxon, ugh. :-)  I hate switching packages around, mostly because 
Java packages are such a pain to setup in my experience.  How come this 
missing feature isn't mentioned in the online book?  Are there other 
undocumented missing features I should be aware of?  (After I get these 
solved then I get to try and figure out why I couldn't get the Apache 
Xinclude parser to load properly, and want to make sure I'm not setting 
up any incompatibilities.  One problem at a time...)

Bob Stayton wrote:
> Different problem entirely.  Xalan uses its own 'redirect' extension to
> write separate chunks, and that function doesn't accept any of the options
> like indent.  And while Xalan does support some EXSLT functions, it doesn't
> support the document() function which would allow such options.  Can you
> switch to Saxon?
> Bob Stayton
> Sagehill Enterprises
> DocBook Consulting
> bobs@sagehill.net
> ----- Original Message ----- 
> From: "Larry Garfield" <larry@garfieldtech.com>
> To: <docbook-apps@lists.oasis-open.org>
> Sent: Thursday, March 24, 2005 11:14 PM
> Subject: Re: [docbook-apps] base.dir param not working in customization
> layer
>>And I'd even tried the single-quotes to fix a different param issue I
>>was having and didn't think of it here. :-)  That did it, thanks!
>>On a related note, I'm having a similar problem with the
>>chunker.output.indent parameter being ignored.  Whether it's set via the
>>customization file or command line, I still get a line break-free output
>>file.  (This is the one where I DID try putting "yes" in quotes, and it
>>still didn't work, yet didn't think to try that on the base.dir as well.
>><g>)  Would that be a related issue?

Larry Garfield			AIM: LOLG42
larry@garfieldtech.com		ICQ: 6817012

"If nature has made any one thing less susceptible than all others of 
exclusive property, it is the action of the thinking power called an 
idea, which an individual may exclusively possess as long as he keeps it 
to himself; but the moment it is divulged, it forces itself into the 
possession of every one, and the receiver cannot dispossess himself of 
it."  -- Thomas Jefferson

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]