OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Right Arrow In GuiMenu Disappears XSL 1.72

Well, my example had spaces around the character, just not easily visible 
in email.  Otherwise your customization is fine.

According to this page, FOP supports the Symbol font automatically as part 
of the base 14 fonts:


It works for me on a Windows XP box.  I haven't tried it on Linux.  Perhaps 
someone else has seen this problem?

Bob Stayton
Sagehill Enterprises
DocBook Consulting

----- Original Message ----- 
From: "Harry Goldschmitt" <harry@hgac.com>
To: "Bob Stayton" <bobs@sagehill.net>; <docbook-apps@lists.oasis-open.org>
Sent: Saturday, February 10, 2007 6:08 PM
Subject: Re: [docbook-apps] Right Arrow In GuiMenu Disappears XSL 1.72

> Thanks.
> I tried that and the spaces around the # disappeared, so I know I did
> something.  I'm attaching my customization file.  Maybe I made a
> typo.  Can you tell me how FOP finds "Symbol"?  My entities do not
> have anything like Symbol as a file name.
> Harry
> At 1:58 PM -0800 2/10/07, Bob Stayton wrote:
>>Ah, I thought that FOP 0.93 had implemented font-selection-strategy,
>>which allows it to find the Symbol font automatically. But it
>>doesn't, so that has get fixed for fop1.extensions.  In the
>>meantime, use this parameter in your customization:
>><xsl:param name="menuchoice.menu.separator"><fo:inline
>>font-family="Symbol"> &#x2192; </fo:inline></xsl:param>
>>Bob Stayton
>>Sagehill Enterprises
>>DocBook Consulting
>>----- Original Message ----- From: "Harry Goldschmitt" <harry@hgac.com>
>>To: <docbook-apps@lists.oasis-open.org>
>>Sent: Saturday, February 10, 2007 1:01 PM
>>Subject: [docbook-apps] Right Arrow In GuiMenu Disappears XSL 1.72
>>>I had a document that stopped producing PDF using FOP 0.20.5 on
>>>Fedora Core 5, yesterday.  I switched from fop 0.20.5 and
>>>docbook-xsl-1.69.1-5 to fop 0.93 and docbook-xsl-1.72.  I can now
>>>produce PDF output.  I'm using xsltproc from libxml2-2.6.23-1.2.  I
>>>had to remove the --stringparam fop.extentions 1, or fop 0.93 blows
>>>up.  Unfortunately, my right arrow seems to have disappeared in the
>>>My html output still looks OK.
>>>I am still using docbook 4.4.
>>>My input hasn't changed and looks like:
>>>It now produces "Files # Exit", instead of the right arrow where the # 
>>>Any ideas?

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]