OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Problems with bibliography

Hi Niels,
There are two possible sources for this error:

a. It cannot open the bibliography database file.
b. It cannot match the id in the file.

If you look in errlogxslt, does it have an error message about not being able to open the bibliography file? That will determine whether a or b is the cause.

Bob Stayton
Sagehill Enterprises

On 4/6/2015 5:32 AM, Niels Müller wrote:
Hi there

I have for year created my course materials with docbook 5, with no or
very few problems at all.

Recently I reinstalled my laptop with a new Linux, Arch Linux, and after
that my generated html pages from the docbook xml documents
started displaying:

Error: no bibliography entry: Col11 found in

and similar for all bibliography entries.
The bibliography is built according to

and worked splendidly until the reinstallation.

I searched and the only thing I found was something that indicated I had
a similar problem 4 years ago. But the threads do not give away the
solution, and I have no recollection about the solution.

I have tried a verbose output from xsltproc but it reveals nothing more
than the above. The biblio.xml file has the proper url, my browser
displays it, and it does contain the xml:id's that I refer to.

I use make and the makefile:

                 rm -rf site
                 mkdir site
                 xmllint --xinclude \
                                 module.xml > /tmp/docbresolved.xml \
                 xsltproc \
                                 --output site/ \
                                 docbook.xsl \
                                 /tmp/docbresolved.xml \
                                 2>./errlogxslt && \
                 tar czf site.tgz site/*
                 echo "site.tgz ready for deployment"

Does anyone have a clue or intuition?

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]