OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: Re: DOCBOOK: DocBook installation problems.


I am not sure if this will solve your problem,
but I just installed the DocBook 3.1 DTD and 
the DocBook 1.4.8 style sheets, I tried to follow
the installation instructions, but in the end 
this is how I did it. I don't pretend this is
how it should be, but it worked for me, so for
your information..

I removed all old stuff, which I had under
$ rm -rf /usr/lib/sgml
I made this dir
$ mkdir sgml
$ cd sgml

and unzipped here the files as I got them
from the installation appendix instructions:

$ unzip /downloads/db148.zip
$ unzip /downloads/docbk31.zip
$ unzip /downloads/ISOEnts.zip  

Note that this puts the DTD and the entities
in the /usr/lib/sgml directory itself.

Now I copied the docbook.cat to catalog 
$ cp docbook.cat catalog 
And editted it, renaming all "iso-[..].gml"
stuff to "ISO[..]". Seems some incompatibility
between the ISOEnts.zip distribution and the
docbk31.zip distributions. Pretty annoying..

I now reinstalled jade. I use RedHat 6.0, and
I had the rpm's (don't remember where I got these

rpm --install --force /downloads/jade-1.2.1-4.i386.rpm  
rpm --install --force /downloads/jadetex-2.3-2.i386.rpm 

This puts a file called CATALOG in /usr/lib/sgml
I simply appended this to the /usr/lib/sgml/catalog
file I made before.
$ cat /usr/lib/sgml/CATALOG >> /usr/lib/sgml/catalog

It seems to work for me. I got anoyed by the warning
jade:/usr/lib/sgml/catalog:22:0:W: DTDDECL catalog entries are not supported
So I removed the DTDDECL line from the catalog. Hope
that won't case problems.


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC