----- Original Message -----
Sent: Wednesday, September 08, 2004 10:36
Subject: RE: [ebxml-iic] Section 7.1 of
Test Framework revision.. using Jacques workflow approach (option B)
No big deal
you missed the call - there will be other ones...
I think we
should phase the "abort" for a later release after this
is too recent a feature, and more thinking is needed on it, even if we seem to
agree on an interpretation.
"return" is OK however, as it is really a convenience faeture clearly
understood with limited implications.
- I think
we should give it more exposure and move it up in Part I , e.g. as a new
the section 3.3 "executing test cases".
[MIKE] - I'm all for
introducing the scripting sooner.. but am wondering just how to put it into
section 3.. which is titled "Test Framework Components"
and describes the
Test Driver and Test Service in detail.
I would be in favor of
adding a "Section 4 - Test Case Execution" .. and putting it in there.
That would also mean removing the current section 3.3 "Executing Test
and moving it into
section 4 as well... since it really doesn't belong in the "components"
section either. Comments? It seems logical to have section 4
follow after the
description of the Test
Framework components. I've modified the first attached document to
reflect this proposal, (as an example). I am also including a second
I am even
in favor of moving it up further than that:
fit just before Section 3.2.4 (i.e. just after the general description
of Test Driver and Test Service,
the lengthy description of Test Service actions (3.2.4),
people have a feel of how all this works together.
[MIKE] - Unless we
change the name of section 3 (from "Test Framework Components") , I'd vote to
add a section 4 titled "Test Case Execution". I feel the the flow is
smooth when we
introduce the two major components of the Test Framework, then dive into
scripting and its semantics. I think that this deserves its own section,
or after the
introduction of the Test Framework Components.
need to extend a bit with succinct and informal introduction of some
notions used (GetMessage, PutMessage, TestAssertion) as we already
second option would give something like:
Service (would contain 3.2.1, 3.2.2, 3.2.3)
Execution of a Test Case in the Test Driver (formerly 7.1)
Messaging Actions and Messaging Services" (formerly 3.2.4)
Interface for Test Driver and Test Services (formerly
[MIKE] - I'll create 2
versions ( insert section 7.1 in both places, and we can make an asessment of
which seems appropriate )
put it as 3.3 above, or just at the very end pf Part 1, I think "7.1" is at
its place in Part 1, as it
the behavior of the test Driver. Part II is about the representation of Test
Suites, which is not really the
of 7.1. which is rather to give a flavor of how test case operates when
executed, what it can do (i.e. what a test driver
And for the
editing of 7.1, again I'd forget about "abort" operator, and rather
discuss on the several points (most editorial)
I reported in "section7.1-JD1_MK_JD2_MK2-JD3.doc"