OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

office message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [office] Namespace 'of' for formula expressions

If the alias is "of" 99% of the time, it still breaks simple tools.  We really either need to mandate a prefix ("shall") or state that it is is implementation-dependent behavior, as any other namespace alias would be.

Of course, if someone tries to mix ODF with some other ML that makes the same claim about the absoluteness of the "of" alias, but uses it as an alias for another namespace, then the whole world breaks.

What are we talking about, in the end, for application complexity to handle an arbitrary alias?  A hashtable of aliases to namespace URI's?  I think one can still have a very simple script and still allow a hashtable of that sort.


"David A. Wheeler" <dwheeler@dwheeler.com> wrote on 04/11/2008 05:16:26 PM:

> Eike Rathke:
> > Pardon? Sorry, I'm not sure I got that question correctly. If you're
> > referring whether aliasing the alias to arbitrary different names should
> > be allowed: I don't think so. IMHO it should be a fixed value for
> > simplicity, so yes, "of" would be the required namespace alias.
> Strictly speaking, from an XML point of view the "of" namespace
> alias could be any name; "aklfjsajfslkf:" would be fine as long as
> the matching namespace definition gave the same OpenFormula namespace.
> BUT: I think we _should_ limit or strongly encourage, the namespace
> alias to be "of" exactly, at least when it's inside an OpenDocument
> document.  The reason is that there are a lot of simple tools/
> libraries that don't handle namespaces exactly "correctly".  If we
> always use "of:", then the simple tools will work.... just grab the
> strings, and yank off the "of:" in front.  We want people to be able
> to develop simple tools to extract data from a document, and making
> that prefixed fixed simplifies their lives.
> There is the problem of nesting; I suppose we could change it to
> "should", if someone believes that's important.

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]