[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: Re: [pkcs11] Proposal: Define CKA_JAVA_MIDP_SECURITY_DOMAIN constants
On 6/26/2013 1:13 PM, Michael StJohns wrote:
For your proposals, you should define CK_MIDP_DOMAIN, CK_MIDP_DOMAIN_PTR, CK_CERTIFICATE_CATEGORY, CK_CERTIFICATE_CATEGORY_PTR and update the attribute typing for CKA_CERTIFICATE_CATEGORY (table 23) and CKA_JAVA_MIDP_SECURITY_DOMAIN (table 24) to point to those types. (One of the reasons I like CKCM_ et al is because for your description of those types you can just point to the appropriate prefix as being part of the type rather than doing an enumeration in multiple places).
*sigh* Sorry - thinking out loud. These are mostly already in your changes.