OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

provision message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: ReferenceType#toPsoId (was"Re: [provision] Some comments on Draft 6 of the spec").

Bohren, Jeffrey wrote:

>Line: 1189 In the example change toPsoId to psoID. The XSDs should be
>changed as well.
This was changed from "psoId" to "toPsoId" when you addressed XSD issue 
This issue was recorded in draft_13_xsd_issues.txt as follows:

>  57.    Rename ReferenceType#psoID to "toPsoId".
>         (Make clear that this specifies the "to" object.)
The intention was to make it clear that the psoId is that of the "to" 
object.  (Since any reference connects two objects, psoId could refer to 
either the "from" object or the "to" object.)

 If a reader thinks about this long enough, the reader will probably 
conclude that the "to" object is the only one you need--since the 
reference itself appears as <capabilityData> in the context of a 
specific object.  However, it costs us only two letters to save the 
reader this head-scratching moment....

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]