Subject: A new name for <difference>?
A name change for <difference> was suggested on this list way back in February. In fact, the original post on this was the fifth message on this list. http://lists.oasis-open.org/archives/relax-ng/200102/msg00004.html James' reasoning was that if we are using <choice> rather than union (and I might add nothing instead of <concur> instead of intersection %^}), we may well come up with another, nonmathematical name for <difference>. Some suggestions from James have been: <except> <butNot> <allBut> We closed this issue a few weeks ago (http://www.oasis-open.org/committees/relax-ng/issues.html#differenceName) but with this proviso: "TC's general feeling was, there is no good reason to change it. On 5/31/2001, TC has decided to close this issue without any action **until someone bring up a new material***." (My emphasis.) Just this week, Murata-san suggested (http://lists.oasis-open.org/archives/relax-ng/200106/msg00227.html): <anyNameExcept> <anyNsNameExcept> which are very precise. I think one reason why we have not changed the name of <difference> is because we haven't heard a bell-ringer yet. Little unresolved issues like this gnaw at me, so just for fun, I have done a bit of brainstorming in searching for an alternative name. This is what I have come up with: <omit> It is simple, clear, and I think it has the right sense, just as well as <choice> captures union. <omit>, I think, carries the sense that you are taking out only part and leaving the rest be, the same as the all-but or any-except sense. Some winnowed chaff from my own cogitations: <exception> <exclude> <exclusion> <barring> <remove> <saving> <block> <leaveOut> <leaveBehind> <jettison> <reject> An old rule in collaborative writing is "You can trash my idea /if/ you can come up with something better!" Try to come up with something better. Mike ==== Wy'east Communications http://www.wyeast.net mailto:email@example.com
Powered by eList eXpress LLC