[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: RE: [sarif] Change to invocation.processSuccessful
After (much!) more discussion, we renamed this property to invocation.toolExecutedSuccessfully. This is the last rename of that property, I promise!
I made this change directly in the Provisional Draft.
I’d accept that.
Can we consider a more descriptive name?
‘processExitedSuccessfully’ for example?
In merging the change for #115 (process outcome), I made a substantive change to the description of the default value for the invocation.processSuccessful property:
If this property is absent, its value SHALL be taken to be true if the exitCode property (§3.13.8) is present and has the value 0; otherwise its value SHALL be taken to be false.
If this property is absent, its value SHALL be taken to be false if the exitCode property (§3.13.8) is present and has a non-zero value; otherwise its value SHALL be taken to be true.
Please reply if you disagree.