Subject: Change draft for #279: logicalLocation.kind changes
I pushed a change draft for Issue #279: “logicalLocation.kind: remove "package" and "function"”:
We will move its adoption at TC #28 on Wednesday November 28th.
This was originally titled “Add "class" to logicalLocation.kind”, based on a suggestion from Jim Kupsch. Michael and I discussed this in-issue and concluded that "class" was not needed since "type" already exists. In the course of the discussion we concluded that "package" was wrongly included (since it signifies a physical packaging mechanism, an issue also, IIRC, raised by Jim). We also decided that "function" was not needed because it’s covered by "member".
See the in-issue discussion for more details. One thing that isn’t there is Michael’s contention that “member” covers function even in a non-OO language like C, because you can consider a function to be a member of a global namespace.