OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

virtio-dev message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [virtio-dev] Re: [virtio] [RFC PATCH 1/3] notifications: unify notifications wording in core

On Wed, 11 Apr 2018 14:35:23 +0200
Paolo Bonzini <pbonzini@redhat.com> wrote:

> On 11/04/2018 04:19, Stefan Hajnoczi wrote:
> > On Wed, Apr 11, 2018 at 12:11:25AM +0200, Halil Pasic wrote:  
> >> Let us unify the wording when talking about notifications. This change
> >> establishes the terms available buffer notification for what was usually
> >> simply called notification or virtqueue notification in v1.0 and used
> >> buffer notification for what was usually called interrupt.
> >>
> >> The term configuration change notification in kept where called so and
> >> consolidated where it's called configuration change interrupt or
> >> similar.
> >>
> >> The changes done here are limited to the core part, and don't
> >> conceptually involve neither the transports nor the devices (references
> >> are updated though). Future changes should address these parts.  
> > 
> > Nice, I think the cleanup is worthwhile.  
> I agree.  I wondered if we should use the term "used buffer interrupt"
> and "available buffer notification".  In the common case I think it
> would be clearer, though there are cases such as vhost-pci where the
> roles are swapped.

If it is swapped in some cases, it is bound to cause confusion for
those. I'd vote for using "notification" in both cases, as this patch
is doing.

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]