OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

wsrp-wsia message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: RE: [wsrp-wsia] [I#155] Rename 'FAULT' entityStateChange flag

This looks good. There is a slight problem in that the "Clone/CloneOnWrite"
value does not fit in with the "R/O" and "R/W" values, which gets me to
thinking that maybe the field _name_ is the problem.

It seems to me that what we're trying to do here is let the Consumer tell
the Producer what to do on a change of entity state. So maybe the field name
should be "onEntityStateChange", with the "R/O", "R/W", and "CloneOnWrite"

Now looking at the above, it seems that only "CloneOnWrite" fits the new
field name. So how about - 

onEntityStateChange = "ChangeEntity", "CloneEntity", "Fault".


-----Original Message-----
From: Rich Thompson [mailto:richt2@us.ibm.com]
Sent: Mon, November 25, 2002 15:24
To: wsrp-wsia@lists.oasis-open.org
Subject: Re: [wsrp-wsia] [I#155] Rename 'FAULT' entityStateChange flag

I have been mulling this, but haven't worked all the way through the idea
formulating in my head around this issue. I'll toss it out anyway for other
people to consider. :}

I think the semantics of where we have arrived might be better served if
the variable was named "entityState" and it had enumerated values of
"ReadOnly", "ReadWrite" and "Clone" (or "CloneOnWrite").


                      Gil Tayar

                      <Gil.Tayar@webcol        To:
                      lage.com>                cc:

                                               Subject:  [wsrp-wsia] [I#155]
Rename 'FAULT' entityStateChange flag 
                      11/24/2002 06:48




Issue: 155
Status: Active
Topic: interface
Class: Minor_Technical
Raised by: Michael Freedman
Title: Rename 'FAULT' entityStateChange flag
Date Added: 24-Nov-2002
Document Section:   v8.5/5.3.3
With the reworked semantics of the entityStateChange flag 'FAULT' no longer
seems an appropriate name.  Read-only might be a better name -- or
something else.  This is because it seems to direct the producer to not
allow writing but doesn't define any semantics for the consumer to follow
up if the producer really wanted to do the write.

Gil Tayar

To subscribe or unsubscribe from this elist use the subscription
manager: <http://lists.oasis-open.org/ob/adm.pl>

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC