[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]
Subject: RE: [wsrp][wsia][wsrp-wsia joint interfaces][Draft Spec 0.43]Sess ionand Entity Handles
In the interest of sanity and progress, I have broken up Rich's, Michael's, Monica's and Eilon's emails into four subjects - "Shared Transient Information", "Persistent Information Scope", "createEntity/createTemplate/createPortlet", "session and entity handles", and "Property lists".
This email will deal with Session and Entity Handles, and the relevant quotes from the emails and my reply to them:
> Rather than "Manifestation", I would propose using "Entity" to describe the
> thing from which markup may be requested. I think it has the right level of
> opacity (Consumer has no idea what kind of entity it is) while carrying
> appropriate semantics (a thing that may be interacted with). Using these
> terms, there was also an open question at the end of our last call related
> to whether there were both persistent and transient entities ...
> If we are going to support explicit lifecycle for both of these, I would
> handle createEntity(handle, propertyValues)
> sessionID createSession(handle, propertyValues)
> think everybody is pretty much on the same page with regards to the term "session"
> which identifies the transient state. (And, as Rich noted, to people that come from
> an OO background, this would be the same as an object instance).
> The tougher one is the persistent key, which in WSRP is typically referred to as
> "instance", but as Rich noted this may be non-intuitive to people from an OO
> background (who think of transient object instances), and hence the need for a
> new term.
> Would you find the following, radically simplified, suggestion for an operation name intrusive:
> Wouldn't you tend to think that "ID" hints towards persistence and "Handle" hints
> towards transience and not vice-versa?
So now Gil writes:
Actually, my "Manifestation" was meant to describe what is in this email roundup described as "session", while I think Rich thought it was about the persistent thingie, but as discussed in a previous email, the persistent "entity" is (arguably) a solely WSRP concept, so given that, and given Eilon's comment, we could change the term from entity to portlet, and stay with "session". The question is, what do we call the WSIA ____. A WSIA Service? A WSIA Component?
Given that, this is my take on terminology:
Portlet - the persistent thingie which WSRP should define in exact terms.
WSIA Component - The thing on which you invoke the operations (e.g. the Web Service that includes those operations).
Session - the "user session" the WSIA Component is "in" when it is "running".
And my take on the handle/ID issue:
sessionHandle = createSession(...)
Powered by eList eXpress LLC