OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: DOCBOOK-APPS: Problems with tables using XSL FO stylesheets.

I've been trying to get the tool chain DocBook -> xsltproc -> passivetex
-> pdf to work.  I've run into two problems doing this.  The first
problem involves xsltproc.  I tried to run xsltproc with Norman Walsh's
fo stylesheets using the command:
xsltproc -o book.fo
/usr/share/xml/docbook/docbook-xsl-1.51.1/fo/docbook.xsl book.xml
I get the error:
Error Undefined namespace prefix
xmlXPathCompiledEval: evaluation failed
Segmentation Fault

So, I tried using an older version of the fo stylesheets and 1.48 or
1.50.0 seemed to work well with xsltproc.

Now I ran 
pdfxmltex book.fo
using the 1.50.0 stylesheets.  It ran okay for a bit but crashed on this
! Illegal unit of measure (pt inserted).
<to be read again>
l.142 ...00%:><fo:table-column column-number="1"/>
<fo:table-column column-nu...
This is using an informal table in the DocBook code.  Passivetex
installed fine and the test documents which were provided also ran
without errors.  Could anyone shed some light into this?

Eric Baudais

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC