OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: Re: DOCBOOK: keeping original html markup in final documents

On Fri, May 31, 2002 at 02:51:22PM +0200, Yann Dirson wrote:
> As usual, run "jade pat/to/xml.dcl yourdoc.xml", or use an XML-aware
> jade wrapper that will do that for you (sgml2x does, I suppose
> docbook-utils does as well).

--- CUT ---
port50-2:~/mydir$ jade /usr/lib/sgml/declaration/xml.dcl testform.xml 
jade:testform.xml:2:28:E: cannot find "dbforms.dtd"; tried "dbforms.dtd", "/usr/local/share/sgml/dbforms.dtd", "/usr/local/lib/sgml/dbforms.dtd", "/usr/share/sgml/dbforms.dtd"
jade:testform.xml:2:28:E: DTD did not contain element declaration for document type name
jade:testform.xml:3:5:E: element "book" undefined
jade:testform.xml:4:6:E: element "title" undefined
jade:testform.xml:5:8:E: element "chapter" undefined
jade:testform.xml:5:15:E: element "title" undefined
jade:testform.xml:6:5:E: element "para" undefined
jade:testform.xml:8:15:E: element "programlisting" undefined
jade:testform.xml:15:5:E: element "para" undefined
jade:testform.xml:15:18:E: element "html:input" undefined
jade:testform.xml:17:18:E: there is no attribute "action"
jade:testform.xml:17:31:E: element "html:form" undefined
jade:testform.xml:18:5:E: element "para" undefined
jade:testform.xml:18:21:E: element "html:button" undefined
jade:testform.xml:22:24:E: there is no attribute "language"
jade:testform.xml:22:29:E: element "classsynopsis" undefined
jade:testform.xml:23:10:E: element "ooclass" undefined
jade:testform.xml:23:21:E: element "classname" undefined
jade:testform.xml:24:10:E: element "ooclass" undefined
jade:testform.xml:24:20:E: element "modifier" undefined
jade:testform.xml:24:49:E: element "classname" undefined
jade:testform.xml:25:10:E: element "ooclass" undefined
jade:testform.xml:25:20:E: element "modifier" undefined
jade:testform.xml:25:49:E: element "classname" undefined
jade:E: cannot find "testform.dsl"; tried "testform.dsl", "/usr/local/share/sgml/testform.dsl", "/usr/local/lib/sgml/testform.dsl", "/usr/share/sgml/testform.dsl"
jade:E: specification document does not have the DSSSL architecture as a base architecture
--- CUT ---

so it seems it doesn't find dbforms.dtd, which is in /usr/share/sgml/docbook/custom/html-forms/1.0/dbforms.dtd

but I really don't know how to tell it where to search...

I'm actually reading Dave's FAQ and http://docbook.sourceforge.net/projects/dsssl/doc/install.html but it is obscure to me.


Jerome Alet

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC